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ELBA

 The folder extracted from the Toscanal package also contains start files to execute Elba.

(d On a Windows OS double-click the batch file run-elba, on a Linux or Unix OS choose
runelba.sh to start Elba.

] Elba always opens the last file that was used, we would like to create a new file, so choose File
-> New:




ELBA - STEPS

(2] Elba -
File Edit View Tools Help

- | New Diagram..] H System Description.. H Database Connection.

Diagrams: Movement Grid Rescale

[use

[

Remove

Duplicate




ELBA — Connect ELBA to the database

(£ Databas ey

Database Type:

[ File > New
J Embedded DBMS > Use selected type
i® Embedded DEMS

The database connection dialog will open ) JDBC

i ODBC Source
i1 Access File

i1 Excel File

Use selected type == Cancel




ELBA — Connect ELBA to the database

3 File > New & Datebese 8
Connection Details:
J Embedded DBMS > Use selected type SOL Fil Location.
(] SQL File Location > Browse > Connect
(use the processed .sql file generated by this tool) .
Connect == Cancel



http://www.cs.ubbcluj.ro/~fca/research/web-log-processing/transform-sql-files-in-simple-format-so-that-elba-and-toscanaj-can-work-with/

ELBA — Connect ELBA to the database

0 File > New |£| Database connection *
Select Key:
J Embedded DBMS > Use selected type Select table for objects:
1 SQL File Location > Browse > Connect RESULTS_2013 —
(use the processed .sql file generated by this tool) Select column for objects.
[ Select table for objects \D: Integer —
J Select column for objects

Done Cancel



http://www.cs.ubbcluj.ro/~fca/research/web-log-processing/transform-sql-files-in-simple-format-so-that-elba-and-toscanaj-can-work-with/

ELBA — Connect ELBA to the database

. & Database connection >
3 File > New e
Select Key:
J Embedded DBMS > Use selected type Select table for objects:

(J SQL File Location > Browse > Connect
(use the processed .sql file generated by this tool)
J Select table for objects

J Select column for objects

RESULTS_2013

Select column for objects:

P Success >

@ Database connection established

(J Now the database connection should be established.

OK

Done Cancel



http://www.cs.ubbcluj.ro/~fca/research/web-log-processing/transform-sql-files-in-simple-format-so-that-elba-and-toscanaj-can-work-with/

ELBA’s — Main Window

J consists of two parts;

L LEFT: display all conceptual scales that have been created.
The order of the scales can be changed here, they can be selected, duplicated and deleted.

J RIGHT: the place where the diagrams will be manipulated.

 three buttons:
(J New Diagram: allow you to create a new diagram

] System Description: opens a window with a little HTML editor. Here you can enter additional
information about the CIS, which can be accessed from within Toscanal.

(] Database Connection: reopens the database dialog



ELBA — Creating diagrams

J Attribute List: offers an attribute centered view which allows creating complex scales
intuitively

(] Context Table: is the manual version for experienced users

(J Nominal Scale: requires disjoint attribute values |£| Elba

File Edit View Tools

[ Ordinal Scale: display numerical or attribute values .. I

that have a linear order [N attribute List "™ Description... | Database Connection..

Diagr Context Table | ;| Movement Grid
Nominal Scale [ Juse + |:
Ordinal Scale |

Grid Scale

(] Grid Scale: are combinations of two independent
ordinal scales




| Attribute List x
(E2]

Scale Title: | |

Label Mame S0L Clause

ELBA — Attribute List

[ Title: the title of the new scale.

(J Label Name: appear in the diagram as attribute label

Remove selected row ‘

i® Use all possible combinations

(J SQL Clause: selects objects from db that have the ) U ol combinations existing n he database
desired attribute. [ crome | [l conca

[ Use all possible combinations: a diagram of all listed attributes will be created,
whether there exist objects in the database for each possible combination of attributes or not
(theory driven and data driven conceptual scaling)

(J Use only combinations existing in the database: the diagram will just consist of concepts that
are derived from the data (data driven conceptual scaling)

(] Create: closes the window and displays the created diagram in the main frame of Elba



ELBA — Attribute List

[£] Etba

n File Edit View Tools

| New Diagram... “ System Description H Database Connection... ‘

Diagrams: : Movement Grid Rescale Edit
: ditive

|Chain

Node

Ideal ﬁ

pier NOT (chain like "4EE] ey AND

NOT (c[LA]like '%1 ') AND

|| Attribute List *
NOT (chain like " %'
Scale Title: |Interesting Classes | (cNOT (chain like '%10__%'") AND
Nd NOT (chain like '%11__%") AND
. Label Name S .2m NOT (chain like '%12__%") AND ;‘ND
L/ chain like __%' =
LE chain like %11__%' (chail:=200% T—%") AND
LT chain like '%12__%" NOT (chain lifNOT in i
LP chain like %21__ %’ NOT (chain |i NOT (chain like '%10__%') AND
; ; (cl
L chain like '%22__% (cH NOT (chain like '%11__%") AND
i in like ' 0/t
NOT (chain like '%10__ %) AND ;\I SOL (C?ari]”_"kl‘?k'% Ng;ﬁ?ﬁ;’; '-'5,?1 1519/3:&3 "
NOT (chain like '%11__%') AND -1 (chainlike ' inlike %12 %'
NOT Echain like '%12:%'; AND '{k (chain like * ___;C::,':__f'ke %12__%) AND
S : IAND |[-..2 more... T
Remove selected row | 5 (chain like '%10__%") AND %) AND T2 more... |
: NOT (chain like "%11__%') ANDp— , M.nV/ (chain like '%12__%") AND
() Use all possible combinations NOT (chain like '%12__%") ANDfe '%10__%') AND .2 more... -
{® Use only combinations existing in the database : .2 more... like '%11__%") AND _{
; Ng NOT (chalj (chaiplike '%12 %" AND
i NPT Y PV VT
| Slas | Sl 2 ZN‘ZL (chain like %10__%") AND TA’O)/ST\ED
TG NOT (chain like '%11__%') AND ,\—N"D
om (chain like '%10__%'") AND
(chain like '%11__%") AND 5)
(chain like '%12__%') AND AND
: .2 more... D
[w | vom ] : [--2n] (chain ke %11_%") AND
5 (chain like '%12__%") AND
W: ...2 more...




ELBA — Attribute List

 the labels you entered as attribute labels above the nodes representing the concepts

 the generated SQL queries covering the objects in the database appear below the nodes

[ the labels of attributes and objects can be hidden via the “View” entry in the menu bar.

| £ Elba
File Edit | View Tools

New Did  Setminimum label size b | || Database Con

¥ Show Attribute Labels :
Diagrams: _ Grid
M Show Object Labels

‘Interesting Classes [rramve| ¥ [ |use




* Please note that this option is recommended to experienced users.

ELBA — Context Table

[ a new window with an empty formal context i _ —
[ enter the context's name = ¢
] objects: SQL expressions Double click here

] attributes: the labels that should appear in the diagram.

(1 double clicking in the cells: the incidence relation between
objects and attributes can be established

| ndaovjects | | addtiributes | | cnecke | | create | | cancel |

(] Add objects and Add attributes: the context can be extended ST

hooves = %' and not m...

mane = "%’ and hooves ...




ELBA — Nominal Scale

 The nominal scale generator provides a view on the database.

(] After selecting a column on the left side of the window, all entries of the selected column are

displayed.

|£] Mominal Scale Generator

Scale Title:

Columns

|RESULTS_201 3.COMPORTAMENT ‘v‘

Available Values

NULL
intense
normal
relaxed

Selected Clauses

| £:| Nominal Scale Generator

x
Scale Title:
Columns Selected Clauses
‘RES“LTS 2013.COMPORTAMENT | - ‘ RESULTS_2013.COMPORTAMENT = ‘inten
RESULTS_2013.COMPORTAMENT = "norm
T T RESULTS_2013.COMPORTAMENT = 'relax
NULL

4] I [ T»

AND | | OR ‘ ‘ NOT ‘

| Create H Cancel |




ELBA — Ordinal Scale

[ Using this dialog requires numerical data

 The drop-down field “Column” contains all columns of the database that consist of numerical

data. Types: - |
I
U increasing, exclude bounds: S 5
[ increasing, include bounds: e "
] decreasing, exclude bounds: ——
[ decreasing, include bounds: ot

produce chain-formed lattices

J both, increasing side includes bounds:

J both, decreasing side includes bounds:

produce so called interordinal scales, which are combinations of two ordinal scales of a single attribute
defining ranges of ordinal data.



ELBA — Grid Scale

O The resulting diagram can be compared with a matrix containing all combinations of all values
of both attributes.

| £ Grid scale editor P4
Title:
Column: Column:
|RESULT572G13‘ILCLASS |v| |RESULT872O13AF7CLASS |v|
Type: Type:
|mcreasmg.exclude bounds |v| |mcreasmg.exclude bounds |v|
Dividers: Dividers:
Enter Value: 0 Enter Value: 1000
—y I

6 1200
Min: .0 Min: .0
Max: 2212.0 Max: 2212.0
Average: 368.0 Average: 667.0

Remove | | Remove All R | | Remove All |




ELBA — Manipulationg diagrams

J movement options for diagrams can be accessed by clicking on the button below “Movement”
in the panel above the diagram view.

 start to organize the diagram from top to bottom:
J Additive: click on a node and drag; dragging a node also moves other nodes;

[ Chain: click on a node and drag; dragging a node also moves other nodes;
this feature maintains the vector space the layout is based on.

] Node: just moves the selected concept.
J Ideal: moves the node, considering that are all subconcepts of the selected concept.
 Filter: moves the nodes, considering that are all superconcepts of the selected concept.



ELBA - Grid

[ activate or change a line grid e || e [ e

(1 Select the box to activate of hide the grid.

1 Clicking on + or - change the grid's scale.




ELBA - Rescale

J you can change the size of the nodes and their labels.




ELBA - Edit

J add additional information abo ut the current scale to the CIS by selecting the “Description”
button

(d These descriptions can be accessed in Toscanal.

[ Clicking Context... opens the context editor




ELBA — Context Menu

 Right clicking the attribute label of a concept opens a context menu where you can access the
description editor and rename the attribute without losing the diagram layout.




ELBA — The menu bar

] File

(J New, Save, Save As
O Export (PNG, JPEG)

J View
O hide or show the attribute and object labels.
(] set a lower limit for the font size used in the labels.

J Tools

() Export Realized Scales: Creates a XML files containing all concepts and scales of the CIS with their extent,
intent and contingent sizes.

EIf!Elxport Database as SQL: The database the created CIS is based on can be hereby easily exported into a SQL
ile.

(] Create Speed Optimized System: a CIS on a large database can be slow if the queries are complex. To speed
up such a system, Elba offers you to create a new, equivalent system that uses simpler queries.

J Check Consistency with Database: This feature checks the consistency of the created scales with the
data(lf_a_se_. You get a notification if the SQL is not correct, the SQL clauses do not cover the data or if they are
not disjoint




Toscanal




Toscanal

 is a browsing frontend for Conceptual Information Systems (CIS) in the tradition of the
Windows-based Toscana tools.

s _——|Menus |
Available | =T0 s e |
Diagrams | \[z=zr™—T Toolbar
e W
ks
Selected
Diagrams
Diagram
Preview Diagram
View




Toscanal

J The main part is the diagram view

J The diagram preview shows the same diagrams, but with reduced labeling.
J The diagrams are selected by their title from the list of available diagrams in the upper left corner.
 This list contains all diagrams defined in the conceptual information system currently opened.

 The list below is the list of selected diagrams. Here all the diagrams used in a particular analysis
session are shown.

J double-click on diagram title: select diagrams from the list
J click on ADD SELECTED button: select diagrams from the list
[ click on REMOVE LAST button: remove the last diagram from the list

(J The order of the selected diagrams can be changed by dragging the names in the list.



Toscanal — Reading line diagrams

[ There is always a top and a bottom node.

(1 The top represents the concept of every object
available.

Object Label 4
|(showing object count)

(J The bottom represents the concept of everything
being true: any object attached to it has all attributes
in the diagram.

J Features: (&) o x
d View -> Show Concept Information A::mw-‘
U Toscanal will display the intent and the extent of the concept. |-LE

Objects (2670):

 Right Click -> Export Concept Information
[ Single Click => Highlighting

Mot queried (too marny)




Toscanal - View Options

dCount: how many objects belong to a particular concept — either as exact matches or as part of
the extent;

 List: enlists all the objects for a particular concept.

 Distribution: is similar to the count option, but instead of displaying the absolute numbers, the
percentage of all objects is displayed.




Toscanal - Nesting Line Diagrams

[ Toscanal allows nesting one diagram (the inner diagram)
into another diagram (the outer diagram).

(J Each of the inner nodes of this diagram represents a
combination of attributes from the outer and the inner
diagram.

1 Highlighting can be used in the same way as in the
normal (flat) diagram.




Toscanal — Printing / Exporting diagrams

1 File > Print
(J Default: this is the normal mode with the color gradient

J Grayscale: the gradient used goes from black (top) to white (bottom)
J White nodes: all nodes are white

[ Black nodes: all nodes are black

(J User Defined: this schema can be changed in the preferences

3 File > Export Diagram (png, jpg)




