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LATEX VIA SCIENTIFIC WORKPLACE

Valeriu Anisiu

Rezumat. Lucrarea prezintă modul de utilizare a programului Scientific
Workplace ı̂n vederea obţinerii unor documente redactate profesional, desti-
nate publicării sau prezentării. Se insistă asupra redactării corecte ı̂n limba
română cu respectarea regulilor tipografice şi de punctuaţie ı̂n vigoare.
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1. INTRODUCERE

La ora actuală majoritatea textelor ştiinţifice sunt redactate ı̂n LATEX
(pronunţat

”
la-tech”). Acesta este un sistem de pregătire a textelor pentru

tipărire (pe hârtie sau ı̂n format electronic) creat de matematicianul şi infor-
maticianul Donald Knuth (varianta numită TEX – pronunţat

”
tech”) şi infor-

maticianul Leslie Lamport. Actualmente sistemul este ı̂ntreţinut şi dezvoltat
de o largă comunitate internaţională. O descriere detaliată incluzând aspecte
de ordin istoric se găseşte ı̂n [1]. O prezentare aproape exhaustivă se află ı̂n
[3]. Pentru cititorii grăbiţi, un tutorial de 10 pagini poate fi descărcat de la
[5].

Sistemul LATEX conţine un mare număr de programe şi fişiere auxiliare (o
distribuţie completă poate avea aproape 100000 de fişiere!). El funcţionează ca
un compilator: pe baza fişierului text (sursă, ı̂ntr-un limbaj numit tot LATEX)
este obţinut fişierul binar de tip (de exemplu) pdf.

Spre deosebire de alte editoare (precum Word), sistemul nu permite vizu-
alizarea aspectului final pe parcursul redactării, ci doar ı̂n momentul ı̂n care
fişierul sursă (.tex) este complet. Acest fapt este privit de iubitorii LATEX-ului
ca având avantajul că autorul se poate concentra asupra conţinutului.

Principalele avantaje ale sistemului LATEX sunt: portabilitate (funcţionează
pe toate sistemele de operare), calitate profesională din punct de vedere tipo-
grafic şi gratuitate.

În această lucrare va fi prezentat modul de utilizare a unui produs (din
păcate comercial) Scientific Workplace (prescurtat ı̂n continuare SWP)
care permite (printre altele) obţinerea fişierului sursă .tex şi a fişierului .pdf
aferent. SWP este practic un editor performant de text şi de expresii mate-
matice care are următoarele avantaje:

• Conţine o distribuţie LATEX relativ completă.
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• Pe parcursul redactării documentului apare şi vizualizarea care este
aproape de cea finală, foarte utilă ı̂n special pentru expresii matematice
care pot fi corectate sau modificate pe loc.
• Nu este nevoie de cunoaşterea limbajului LATEX (deşi o cunoaştere

cel puţin minimală se poate dovedi benefică pentru depanare sau
construcţii speciale). Pe de altă parte, limbajul LATEX nu este compli-
cat şi orice matematician ar trebui să aibă ı̂n repertoriu elementele sale
de bază, acestea fiind utile chiar şi pentru comunicarea unor formule
prin e-mail sau forumuri din Internet.
• Fişierul .tex rezultat poate fi trimis editorului (eventual după o cos-

metizare minimă) iar cel .pdf poate fi tipărit.
• Viteza de obţinere a rezultatului final este mai mare decât ı̂n cazul

scrierii directe a fişierului sursă.

2. INSTALAREA SWP

Pentru a beneficia de SWP trebuie descărcat produsul de pe site-ul pro-
ducătorului:

http://www.mackichan.com

şi instalat.
Fiind vorba de un produs comercial, acesta trebuie ı̂nregistrat (contra cost)

la producător. Se poate ı̂nsă obţine o licenţă temporară gratuită (valabilă 30
de zile).

După instalare, se recomandă activarea tuturor barelor conţinând picto-
grame din meniul View şi din submeniul său Toolbars... şi aranjarea lor
(prin tragere cu mouse-ul) pe marginea ecranului pentru a avea spaţiu de
vizibilitate suficient.

Pentru testarea programului, creaţi un fişier nou cu meniul File>New...,
tastaţi un text arbitrar, salvaţi fişierul tex generat şi accesaţi meniul
Typeset> Preview PDF... După câteva clipe ar trebui să se deschidă
o fereastră a vizualizatorului de fişiere pdf (pe care se presupune că ı̂l aveţi
instalat, probabil Adobe Reader sau Foxit) ı̂n care apare textul tastat an-

terior. În acest moment ı̂n directorul ı̂n care aţi salvat fişierul .tex va exista
şi un fişier .pdf cu acelaşi nume (plus câteva fişiere auxiliare create ı̂n tim-
pul procesului de compilare). Dacă se doreşte doar crearea fişierului pdf fără
vizualizarea acestuia, se accesează meniul Typeset>Compile PDF...

În continuare puteţi face diferite alte teste, dar este bine să ı̂ncepeţi prin
a citi secţiunile următoare. Documentaţia inclusă ı̂n SWP este vastă; dacă
ı̂ntâmpinaţi dificultăţi va trebui să o consultaţi.

În secţiunea 7 găsiţi procedura de urmat pentru lucrul cu diacriticele
româneşti.

Notă: Comenzile File>Print şi File>Preview pot fi folosite doar pentru
depanare ı̂ntrucât nu este invocat sistemul LATEX pentru compilare.
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3. TEXT ŞI EXPRESII MATEMATICE

Editorul SWP are două moduri de lucru: modul text şi modul matematic.

În continuare vom nota prin CTRL+ abc combinaţia de taste obţinută
prin menţinerea apăsată a tastei CTRL şi tastarea caracterelor abc, urmată
de eliberarea tastei CTRL.

Combinaţia de taste CTRL+ T trece editorul ı̂n mod text, iar CTRL+ M
ı̂n mod matematic. De remarcat ı̂nsă că prin meniul Tools>User setup...
semnificaţiile acestor combinaţii de taste (precum şi multe altele) pot fi mo-
dificate de către utilizator. Acelaşi efect se obţine prin meniu Insert>Text
şi Insert>Math sau cu pictograma corespunzătoare.

În fereastra SWP obiectele şi tag-urile (marcajele, vezi ı̂n continuare) pot
fi introduse prin trei modalităţi:

• prin meniurile Insert şi Tag>Apply...
• prin pictogramele de pe bare

e.g.
sau din listele derulante de pe bara de tag-uri

(sunt afişate tag-urile prezente ı̂n dreptul cursorului)
• prin combinaţii de taste (scurtături).

Cea mai rapidă metodă este ultima, dar are dezavantajul că trebuie reţinute
aceste combinaţii. Este recomandabil a se reţine cel mai des folosite astfel de
combinaţii pentru mărirea productivităţii; lista lor completă se află ı̂n sistemul
de ajutor (Help) la keyboard shortcuts.

Orice obiect SWP are asociate mai multe proprietăţi (atribute) care pot fi
activate, dezactivate sau modificate. Pentru a deschide o fereastră cu aceste
proprietăţi, se poziţionează cursorul ı̂n dreapta obiectului şi se execută una
din acţiunile:

– se activează meniul contextual (prin clic cu butonul drept al mouse-ului)

– se execută un clic pe pictograma
– se foloseşte meniul Edit>Properties
– se tastează combinaţia CTRL+F5.
De exemplu, dacă ı̂n mod text cursorul este ı̂n dreapta literei A, avem

posibilitatea plasării unui accent, A putând fi astfel transformat ı̂n Á, Ă, A̧
etc. De notat că astfel de caractere accentuate pot fi preluate şi direct din
bara de simboluri latine (ultimele două pictograme).
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SWP dispune de o colecţie de fragmente1 care poate fi comple-
tată de utilizator. Aceste fragmente pot fi preluate din lista derulantă

şi inserate ı̂n dreptul cursorului. Este ca un fel de
clipboard multiplu permanent.

3.1. Modul text. Prezenţa modului text ı̂n zona ı̂n care se află cursorul este

semnalată de existenţa pictogramei care se transformă ı̂n ı̂n mod
matematic.

În mod text sunt generate zone text (ne-matematic) de culoare neagră; ı̂n
zonele matematice culoarea este roşie.

Există mai multe tag-uri care pot fi aplicate oricărei porţiuni dintr-un text
referitoare la:

• Familia/forma fontului: Normal, Italics, Emphasized, Bold, Roman,
Sans Serif, Slanted, Small Caps, Typewriter
De notat că tag-ul Emphasized coincide ı̂n general cu Italics dacă textul
ı̂nconjurător este normal şi cu Normal dacă textul ı̂nconjurător este cu
Italics.
• Mărimea fontului: tiny, scriptsize, footnotesize, small, normalsize, large,

Large, LARGE, huge şiHuge
• Alinierea paragrafelor (funcţionează şi ı̂n mod matematic): Centered

(centrare), Flush Right (aliniere la dreapta), Flush Left (aliniere la
stânga). Se aplică paragrafelor ce ı̂ncap ı̂ntr-un rând; poate conţine şi
alte construcţii e.g. tabele (vezi mai jos). Pentru centrarea formulelor
este preferat tag-ul Display (v. 3.2) care realizează şi alte formatări.

Normele tipografice insistă să nu fie utilizate prea multe astfel de tag-uri ı̂n
aceeaşi pagină. Menţionăm scurtăturile F4 pentru Normal (elimină tag-urile
privind fonturile), F5 pentru Bold şi F6 pentru Emphasized.

În mod text tasta SPACE este activă pentru o singură apăsare (nu pot exista
două spaţii consecutive); dacă din motive foarte justificate se doreşte spaţiu
suplimentar, pot fi introduse spaţii ı̂nguste (cu CTRL+ , ), spaţii obligatorii

(cu SHIFT+SPACE), spaţii largi (cu CTRL+SHIFT+SPACE) şi câteva spaţii
speciale accesibile prin meniul Insert> Spacing> Horizontal space... sau

pictograma . Aceste spaţii pot fi utilizate şi ı̂n mod matematic.
Recomandare generală: nu ı̂ncercaţi să forţaţi LATEX-ul să formateze textul

abuzând de astfel de construcţii deoarece comportamentul implicit a fost te-
meinic analizat şi produce efectele tipografice optime ı̂n marea majoritate a
cazurilor.

Cu tasta ENTER se trece la un nou paragraf (cu indentare);
SHIFT+ENTER (sau Insert> Spacing> Break> Newline) inserează o

1care sunt de fapt mici fişiere cu cod sursă aflate ı̂n directorul Frags
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linie nouă ı̂n cadrul aceluiaşi paragraf (deci fără indentare). Prin meniul
Tools>User Setup... se poate opta ca tasta ENTER ı̂ntr-un paragraf gol
să fie ignorată sau să genereze spaţiu pe verticală (Big Skip).

Notă. Pentru ca un paragraf să apară fără indentare, se plasează cursorul la
ı̂nceputul său, se accesează meniul Insert> Spacing> Horizontal Space...
şi se alege No Indent.

Dacă dorim să includem ı̂n document conţinutul unui fişier text (de exemplu
listingul unui program scris ı̂n C sau Pascal) putem folosi tag-ul Verbatim.
Fontul utilizat este de dimensiune fixă (toate literele au aceeaşi lăţime, ca şi

Typewriter). În interiorul contextului Verbatim spaţiile contează şi pot fi
folosite pentru indentare. Părăsirea contextului Verbatim se obţine cu tag-ul
Body Text sau tasta F3.

Cu meniul Insert>Table... (sau pictograma ) pot fi construite ta-
bele. Se fixează numărul de linii şi de coloane şi modul de aliniere. După
completarea elementelor tabelului şi plasarea cursorului la dreapta tabelului,
prin meniul Edit>Add row(s)... (sau din meniul contextual) se poate supli-
menta numărul liniilor. Similar pentru coloane cu Edit>Add columns(s)...

În plus, prin meniul contextual pot fi comasate celulele unei linii sau pot fi
adăugate linii separatoare pentru celule.

Exemplu:

Tabel important

cifra
unu 1
doi 2
trei 3

3.2. Modul matematic. În mod matematic spaţiile obişnuite sunt ignorate
de către LATEX; din acest motiv tasta SPACE este inactivată ı̂n mod matematic
(̂ın mod implicit, căci există posibilitatea, agreată de mulţi utilizatori, ca tasta
SPACE să producă trecerea ı̂n mod text; această opţiune se activează prin
meniul Tools>User setup...). Dacă unei porţiuni de text i se aplică tag-
ul matematic, toate spaţiile obişnuite (nu şi cele ı̂nguste, largi etc.) vor fi
eliminate.

Fontul standard ı̂n mod matematic este asemănător cu cel italic (cursiv)
din modul text. Similar cu tag-urile relative la fonturi din modul text, pentru
notarea unor simboluri matematice există următoarele tag-uri care corespund
unor fonturi speciale:

Blackboard Bold (numai pentru majuscule): N,Z,Q,R,C
Calligraphic (numai pentru majuscule): A,B, C,D,P,Q,R (utilizate de

exemplu pentru familii de mulţimi)
Fraktur (conţine litere gotice): A,B,C,D, a, b, c, d
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Bold Symbol: v,V (utilizare de exemplu pentru notarea vectorilor, ı̂n loc

de ~v, ~V ). De notat că spre deosebire de fontul Bold ı̂n mod matematic, fontul
Bold Symbol este ı̂nclinat.

(Nu uitaţi să reveniţi la caractere normale cu tag-ul Normal sau tasta F4.)

Operatorii matematici şi alte semne matematice speciale se află ı̂n bara de
simboluri. Menţionăm aici o scurtătură utilă pentru literele greceşti: primul
caracter tastat după CTRL+ g este transformat ı̂n echivalentul său grecesc.

De exemplu CTRL+ g m generează µ iar CTRL+ g G generează Γ.

Notă. Cunoscătorii de LATEX pot introduce comenzi direct de la tasta-
tură ţinând tasta CTRL apăsată; de exemplu pentru a introduce simbolul de

apartenenţă ∈ (\in ı̂n LATEX) se tastează CTRL+ in .
Prin aceeaşi metodă se pot obţine şi fragmentele (̂ın special cele cu nume

scurte definite de utilizator). De exemplu, putem defini un fragment având

conţinutul Stimate domnule Popescu, (scris cu litere cursive); este suficient

să selectăm acest text şi utilizăm meniul File>Save fragment... (sau să
apăsăm pictograma de lângă lista derulantă a fragmentelor) alegând, de exem-
plu, numele pop pentru fragment. De acum ı̂nainte, tastând CTRL+ pop va

fi inserată această formulă de adresare.

Descriem ı̂n continuare şabloanele utilizate ı̂n construirea expresiilor mate-
matice (introduse prin meniul Insert, prin pictograme sau prin combinaţii de
taste aşa cum s-a menţionat).

• Fracţie: CTRL+ f ; se completează cele două câmpuri (numărător şi
numitor), trecerea de la un câmp la celălalt se poate face cu tasta TAB.
Exemplu: a+1

b = x. De remarcat faptul că fonturile pentru numărător
şi numitor sunt mai mici, dar se poate opta pentru dimensiuni standard

modificând proprietăţile (prin meniul contextual):
a+ 1

b
= x.

• Radical: CTRL+ r ; similar. Exemplu: a
√
b

• Exponent: CTRL+ ↑ ; se completează exponentul. Exemplu: xe

• Indice: CTRL+ ↓ ; se completează indicele. Exemplu: xi

• Paranteze: CTRL+ ( sau CTRL+ ) ; apare o pereche de paranteze

a căror ı̂nălţime se adaptează expresiei ı̂ncadrate. Exemplu:
(
x+ 1

2
10

)
.

Dacă am folosi paranteze uzuale ar rezulta (
x+ 1

2
10 ).

Similar pentru alte perechi de paranteze (e.g. CTRL+ | produce va-

loare absolută |·|); utilizând pictograma se pot construi chiar ti-
puri diferite ı̂n stânga şi dreapta (oricare putând fi vidă) e.g.

[
a
b ,∞

)
,{

x, x < 0
x2, x ≥ 0

.
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• Sume: CTRL+ 7 sau CTRL+ sum ; limita inferioară şi superioară
sunt tratate ca indice/exponent. De notat faptul că pentru limita
inferioară putem avea linii multiple folosind ENTER, de exemplu:∑

a,b∈N
a+b≤n

a · b = 1 · 1 + 1 · 2 + · · ·+ (n− 1) · 1 (de remarcat şi prezenţa

punctelor de suspensie centrate).

• Integrale: CTRL+ i ; limita inferioară şi superioară ı̂n cazul integralei
definite sunt tratate ca indice/exponent. De notat că potrivit regulilor
tipografice, ı̂n exemplul

∫
f(x) dx trebuie inserat un spaţiu ı̂ngust (cu

CTRL+ , ) ı̂nainte de dx. Reguli tipografice mai stricte recomandă ca

operatorul diferenţial d să fie cu font Roman (drept):
∫
f(x) dx.

Utilizând pictograma cu operatori (sume şi integrale) se pot construi
şi alţi operatori: produs, produs tensorial, sume directe, integrale mul-
tiple etc.

• Display: CTRL+ d (sau pictograma ); expresia este afişată ı̂n mod
display adică centrat, pe o linie nouă, cu operatorii de dimensiune mai
mare şi având limitele superioare şi inferioare deasupra şi dedesubt. În
plus, expresia (de obicei o formulă sau o ecuaţie) poate fi numerotată.

Tastând ENTER este creată o nouă linie. Dacă liniile astfel create
sunt ecuaţii, acestea sunt aliniate la semnul = şi pot fi numerotate inde-
pendent. Un astfel de ENTER este util şi pentru

”
ruperea” formulelor

prea lungi care ar putea depăşi marginea din dreapta (bifând even-
tual ı̂n meniul contextual Advanced> Enable Alignment> Single
Equation on Multiple Lines).

Exemplu: egalitatea
∑∞

n=1 n
−n =

∫ 1
0 x
−x dx (Pólya & Szegő) apare

ı̂n mod display sub forma:

(P–S)
∞∑
n=1

n−n =

∫ 1

0
x−x dx.

Acestei formule i s-a ataşat prin meniul contextual o numerotare
“custom” (completând P–S ı̂n câmpul Number) şi o etichetă (pentru
a putea face trimiteri la ea) completând formula-ps ı̂n câmpul key.
• Numele de funcţii şi operatori precum sin, cos, lim etc. sunt scrise

cu caractere drepte (Roman). În mod matematic aceste funcţii sunt
recunoscute şi fontul este schimbat automat. Pentru funcţiile care nu
sunt recunoscute precum arctg trebuie folosit meniul Insert> Math

Name... (sau pictograma ) ı̂n care este introdus numele funcţiei.
Exemple: limn→∞ an, sup

n∈N
an (pentru a doua formulă s-a selectat

poziţionarea Above/Below prin meniul contextual).
Exemplul lim sup

n→∞
sinn = 1 este incorect formatat deoarece au fost

recunoscute două nume de funcţii lim şi sup ı̂n locul uneia singure
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lim sup . Va trebui să folosim Insert> Math Name... pentru a obţine
formatarea corectă lim sup

n→∞
sinn = 1.

• Matricele şi determinanţii se obţin cu meniul Insert> Matrix... (sau

pictograma ) unde se aleg dimensiunile, alinierea şi delimitatorii.

Exemplu: det

[
a b
c d

]
=

∣∣∣∣a b
c d

∣∣∣∣.
• Decoraţiuni (cu meniul Insert> Decoration...): pot fi trasate linii,

săgeţi şi alte câteva simboluri deasupra, dedesubtul sau ı̂n jurul unui

obiect (̂ın mod text sau matematic). Exemple: ÂBC,
−−→
AB, ABC (ulti-

mul este ı̂n mod text).
• Suprapuneri (cu meniul Insert> Label...): plasează deasupra sau

dedesubtul obiectului. Exemple:
b
a, a

b
.

4. REDACTAREA DOCUMENTELOR COMPLEXE

Ne vom referi aici la tehnoredactare, fără a avea ı̂n vedere aspectele legate
de exprimarea matematică aşa cum apare ea ı̂n excelentul eseu al lui Paul
Halmos [2].

4.1. Clasă şi stil, pachete. Pentru crearea unui document, LATEX oferă mai
mule tipuri de

”
matriţe” numite clase. Principalele clase sunt:

• article (pentru articole ştiinţifice conţinând secţiuni dar nu capitole)
• report (pentru rapoarte, cărţi mici conţinând capitole şi secţiuni)
• book (pentru cărţi)
• letter (pentru scrisori)
• beamer (pentru transparente – prezentări, vezi secţiunea următoare).

Opţiuni şi posibilităţi suplimentare sunt oferite prin includerea unor pa-
chete.

Clasa documentului ı̂n SWP este aleasă ı̂n momentul deschiderii unui do-
cument nou (File>New...), dar ı̂n plus sunt oferite şi o mare varietate de
fişiere de stil astfel ı̂ncât aspectul final să fie cel dorit de editor sau utilizator
(majoritatea editorilor au propriul lor fişier de stil (.sty), multe dintre acestea
fiind prezente ı̂n SWP).

Pentru fiecare clasă şi fiecare pachet pot fi setate o serie de opţiuni prin
meniul Typeset> Options and packages... De exemplu, ı̂n cadrul clasei
poate fi ales modul de numerotare a ecuaţiilor şi teoremelor, dimensiunea
fontului principal etc. Prin acelaşi meniu pot fi incluse noi pachete (pe lângă
cele incluse automat de SWP): din lista derulantă obţinută cu Typeset>
Options and packages...> Package Options> Add este ales pachetul
dorit, după care pot fi setate opţiunile sale.

Din numărul imens de pachete şi opţiuni existente menţionăm ı̂n continuare
doar câteva:
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• babel cu opţiunea romanian. Pentru documente ı̂n limba română
asigură scrierea ı̂n limba română a antetelor (Capitol, Secţiune, Cu-
prins, Bibliografie etc.) şi despărţirea ı̂n silabe.
• indentfirst. Simpla sa prezenţa face să fie indentat şi primul para-

graf al (sub)secţiunilor respectând astfel regulile tipografice româneşti.
• geometry. Permite modificarea marginilor documentului. De exem-

plu pentru a seta ı̂ntr-o foaie A4 toate marginile la 2 cm, după inclu-
derea pachetului adăugaţi cu meniul Typeset>Preamble linia
\geometry{a4paper,left=2cm,right=2cm,top=2cm,bottom=2cm}
sau echivalent
\geometry{paperhight=297mm,paperwidth=210mm,margin=2cm}
• setspace. Are opţiuni pentru tipărire la 11

2 sau 2 rânduri.
• nopageno. Este suprimată tipărirea numerelor de pagină.

4.2. Titlul, autorul, alte informaţii. După alegerea clasei şi stilului docu-
mentului se poate trece la redactare.

Vom ı̂ncepe cu introducerea informaţiilor de identificare (titlu, autor, adresă
etc.). Accesând meniul Typeset>Fontmatter... va apărea o mică fereastră
ı̂n care vom completa aceste informaţii. Unele tipuri de documente au infor-
maţii deja introduse şi trebuie doar modificate (şi eventual şterse cele inutile).
Dacă tag-ul Author nu există, el este creat din lista derulantă de tag-uri şi
se completează numele. În cazul mai multor autori se tastează ENTER şi
se scrie pe linia următoare. După completarea ultimului autor se tastează
ENTER după care se introduce tag-ul Title etc.

Pentru ca aceste informaţii să fie tipărite ı̂n fişierul pdf trebuie introdus şi
tag-ul Make Title. Dacă se doreşte crearea unui cuprins se va adăuga tag-ul
Make TOC.

4.3. Capitole, secţiuni, subsecţiuni. Pentru marcarea ı̂nceputului unei
secţiuni se foloseşte tag-ul Section şi se completează titlul secţiunii. În conti-
nuare se introduce conţinutul secţiunii. Se procedează la fel pentru subsecţiuni
şi subsubsecţiuni (dacă este cazul). Aplicând tag-ul Body Text (sau tasta F3)
având cursorul poziţional pe titlul secţiunii, acest titlu devine text obişnuit.

Notă. Dacă se doreşte includerea conţinutului unui alt fişier tex ı̂n docu-
mentul curent, ı̂l putem deschide şi pe acesta (va apărea ı̂ntr-o fereastră nouă)
şi folosim copy/paste. Sau, prin meniul File> Import Contents... este
transferat ı̂ntregul fişier fără afectarea stilului.

4.4. Liste, teoreme, definiţii. Construirea unei liste se obţine cu unul din
tag-urile Bullet List Item, Numbered List Item, Description List
Item.

După completarea unui item se apasă ENTER pentru a introduce itemul
următor; antetul oricărui item (bulina ı̂n primul caz) poate fi şters, situaţie
ı̂n care itemul este comasat cu itemul precedent (ca nou paragraf). Pentru

terminarea listei se tastează F2 sau clic pe pictograma din stânga barei
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cu tag-uri. Listele pot fi imbricate i.e., un item al unei liste poate conţine o
listă. Un exemplu de listă cu buline se află la ı̂nceputul acestei secţiuni.

Pentru a introduce enunţul unei teoreme se foloseşte tag-ul Theorem.
Apare ca antet cuvântul Theorem. Tastând ENTER la sfârşitul enunţului
apare un nou antet Theorem pentru a putea introduce o nouă teoremă. Sau,
putem şterge acest antet şi ceea ce urmează va fi considerat ca nou paragraf al
teoremei precedente. În final, pentru a ieşi din contextul theorem se tastează

F2 sau clic pe pictograma . În acceaşi manieră se procedează cu tag-urile
Definition, Proposition, Corollary etc. (numărul tag-urilor depinde de
stil). Pentru tag-ul Proof apare diferenţa că tasta ENTER introduce un nou
paragraf al demonstraţiei; după ultimul paragraf se tastează ENTER şi apoi
F2.

Modul de numerotare a teoremelor, definiţiilor etc. depinde de stilul ales,
dar utilizatorul are posibilitatea să modifice atât modul de numerotare cât şi
antetul tipărit.

a) Dacă dorim o numerotare independentă pentru toate aceste contexte (i.e.
de tipul T1, T2, D1, D2, T3, T4), ştergem ı̂n meniul Typeset> Preamble...
liniile care ı̂ncep cu \newtheorem şi adăugăm linii de forma
\newtheorem{theorem}{Theorem}%[section]
\newtheorem{definition}{Definition}%[section]
b) Dacă ştergem caracterul % din liniile precedente, ı̂n antet va apărea şi

numărul secţiunii (i.e. ı̂n secţiunea 7 de tipul T7.1, T7.2, D7.1, D7.2, T7.3,
T7.4).

c) Dacă dorim antete ı̂n limba română vom ı̂nlocui mai sus Theorem cu
Teorem\u{a}, Definition cu Defini\c{t}ie etc. (atenţie, cuvintele cu litere
mici theorem, definition rămân nemodificate).

Notă. Introducerea
”
manuală” a teoremelor tastând ceva de felul

Teorema 1. Fie f : R→ R o funcţie convexă. . .
sau numerotarea

”
manuală” a formulelor precum

sin(x+ π) = − sinx (1)
este cu totul nerecomandată deoarece deteriorează aspectul documentului
tipărit şi denotă amatorism. De altfel, o astfel de abordare nu ar face decât să
complice viaţa utilizatorului căci o modificare sau reorganizare a documentului
ar presupune renumerotări şi reformatări.

4.5. Referinţe ı̂ncrucişate şi citări. În lucrările de matematică apar frec-
vent trimiteri2 de forma: vezi Lema 2.3 din Capitolul 7 şi ecuaţia (5). În
LATEX (şi SWP) se procedează astfel: la ı̂nceputul lemei şi al capitolului
ı̂n cauză se inserează câte un “marker” (etichetă) folosind pictograma

”
steag”

sau meniul Insert>Marker... şi i se atribuie un nume sugestiv e.g. L-Borel,

2Pentru a include o notă de subsol (ca aceasta) poziţionaţi cursorul ı̂n dreapta cuvântului
şi accesaţi meniul Insert>Note...
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respectiv cap-convexitate. Etichetarea unei ecuaţii (̂ın mod display) se face
aşa cum s-a văzut ı̂n 3.2, completând câmpul key din meniul său contextual,
ı̂n exemplul nostru ec-Cauchy. Trimiterile vor fi făcute acum prin meniul
Insert>Typeset Object>Cross Refference... sau cu pictograma aferentă.
Pe ecran va apărea: vezi Lema ref: L-Borel din Capitolul ref: cap-convexitate

şi ecuaţia (ref: ec-Cauchy).

Bibliografia se plasează la sfârşitul lucrării. Includerea unui unui titlu bi-
bliografic se obţine cu tag-ul Bibliography Item (pentru următoarele titluri
se poate tasta ENTER la sfârşitul oricărui titlu deja introdus). Va apărea o
mică fereastră ı̂n care vom completa o etichetă (key), de exemplu kopka ı̂n
cazul lucrării [3], după care vom completa numele autorului, titlul lucrării,

editura (sau revista, volumul, numărul, paginile) şi anul de apariţie. În mod
uzual, pentru cărţi, titlul este scris cu italice iar pentru reviste, numele revistei
apare ı̂n italice iar numărul ı̂n aldine (bold), aşa cum se vede la citările [3] şi
[2]. Modul de completare poate depinde de cerinţele editorului; este bine să
citim instrucţiunile editorului şi să consultăm un număr mai vechi al revistei
ı̂n cauză.

Citarea lucrării se va face cu meniul Insert> Typeset Object> Cita-
tion... sau cu pictograma aferentă, completând câmpul key cu eticheta (care
poate fi obţinută din lista derulantă a etichetelor prezente ı̂n document). Pe
ecran va apărea cite: kopka.

4.6. Grafice. Includerea ı̂n document a fişierelor grafice (png, bmp, wmf etc.)

se realizează simplu cu meniul File>Import Picture... Încadrarea ı̂n pagină
poate fi făcută cu mouse-ul sau utilizând meniul contextual.

Graficele incluse nu vor fi plasate ı̂n general pe pagină ı̂n locul de inserţie,
ı̂ntrucât filozofia sistemului LATEX este de a umple armonios fiecare pagină.
Putem totuşi forţa plasarea acestor obiecte flotante la locul de inserţie bifând
opţiunea Here ı̂n meniul contextual.

5. REALIZAREA PREZENTĂRILOR CU BEAMER

Pentru realizarea unor prezentări similare cu cele din Powerpoint dar mult
mai adecvate pentru conţinuturi matematice, LATEX (şi SWP) conţine clasa
de documente Beamer.

Rezulatul compilării unui fişier LATEX de clasă beamer este un fişier pdf

având pagini de dimensiuni reduse (adecvate vizualizării cu un proiector) nu-
mite cadre (frames), fiecare cadru putând avea titlu şi subtitlu afişat ı̂ntr-un
antet colorat.

Pentru a obţine un fişier de clasă beamer, accesăm meniul File>New şi
alegem şablonul Other Documents>Slides-Beamer. În fereastra SWP va
apărea un document standard conţinând câteva elemente tipice şi unele reco-
mandări. Vom şterge documentul pentru a introduce propriul nostru conţinut.
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Primul cadru corespunde paginii de titlu; elementele sale sunt preluate
din Typeset>Front Matter... unde vor trebui ı̂nlocuite conţinuturile
câmpurilor Title, Author, Institute etc. (acest cadru nu apare ı̂n fereastra
SWP ci doar ı̂n fişierul pdf final).

Fiecare dintre cadrele următoare este delimitat de fragmentele Begin-
Frame şi EndFrame care trebuie importate din lista derulantă a fragmen-
telor pentru fiecare cadru. Este preferabil ı̂nsă a utiliza cadre cu titlu (sau
titlu+subtitlu) obţinute importând fragmentele Beamer Frame with Title
respectiv Beamer Frame with Title and Subtitle după care:

– se ı̂nlocuieşte textul Frame Title cu titlul cadrului, de exemplu, Noţiuni
preliminare

– se introduce conţinutul cadrului.
Conţinutul cadrului poate conţine orice construcţie LATEX (inclusiv teoreme,

propoziţii, liste, grafice). Pentru a genera un document ı̂n limba română
(̂ın care să apară, de exemplu, nu Theorem ci Teoremă) va trebui ca ı̂n
Typeset>Preamble... să adăugăm liniile:

\newtheorem{teo-ro}{Teorem\u{a}}

\newtheorem{def-ro}{Defini\c{t}ie}

\newtheorem{alg-ro}{Algoritm}

\newtheorem{axi-ro}{Axiom\u{a}}

\newtheorem{conj-ro}{Conjectur\u{a}}

\newtheorem{cor-ro}{Corolar}

\newtheorem{exem-ro}{Exemplu}

\newtheorem{exer-ro}{Exerci\c{t}iu}

\newtheorem{lema-ro}{Lem\u{a}}

\newtheorem{notatie-ro}{Nota\c{t}ie}

\newtheorem{prob-ro}{Problem\u{a}}

\newtheorem{prop-ro}{Propozi\c{t}ie}

\newtheorem{obs-ro}{Observa\c{t}ie}

\newtheorem{sol-ro}{Solu\c{t}ie}

\newtheorem{rezumat-ro}{Rezumat}

\newenvironment{dem-ro}[1][Demonstra\c{t}ie]%

{\noindent\textbf{#1.} }{\ \rule{0.5em}{0.5em}}

În acest fel vor apărea tag-urile teo-ro, def-ro,. . . , dem-ro alături de
variantele lor ı̂n limba engleză theorem, definition,. . . , proof.

Pot fi incluse secţiuni şi subsecţiuni. Acestea vor apărea ı̂n partea stângă a
cadrului şi conţin link-uri permiţând o navigare rapidă prin document.

Un cadru Beamer poate fi afişat progresiv: importând fragmentul Pause,
afişarea este ı̂ntreruptă ı̂n ideea ca prezentatorul să poată insista verbal asupra
conţinutului afişat ı̂n acest moment. Tastând ENTER, afişarea continuă până
la sfârşitul cadrului sau până la următorul Pause.
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Notă. Este posibil ca ı̂n cazul afişării progresive elementele deocamdată
invizibile (aflate după Pause) să fie totuşi afişate dar şters (i.e. cu cu-
loare gri deschis); pentru realizarea acestui efect se va adăuga prin meniul
Typeset>Preamble... linia
\setbeamercovered{transparent}
Tot ı̂n preambul poate fi schimbată tema implicită (Madrid) cu o alta

(e.g. Berkeley, Berlin, Copenhagen, Darmstadt, Dresden, Frankfurt,

Goettingen, Singapore, Warsaw).

În afară de listele uzuale, ı̂n Beamer există tag-urile Step Bullet List Item
şi Step Numbered List Item pentru care apare o ı̂ntrerupere (similar cu
Pause) după fiecare element (item) al listei. Există de asemenea variantele
Alert Step Bullet List Item şi Alert Step Numbered List Item ı̂n care
elementele listelor apar ı̂n culoare roşie pentru evidenţierea unor idei marcante.

Notă. Dacă prezentarea Beamer este bazată pe o lucrare deja scrisă ı̂n
SWP, putem proceda astfel:

(1) Eliminăm din lucrare porţiunile inutile pentru prezentare (precum
demonstraţiile lungi, rezultatele auxiliare, unele titluri bibliografice).

(2) Salvăm fişierul ı̂ntr-un fişier temporar.
(3) Folosim meniul File>New şi alegem şablonul Other

Documents>Slides-Beamer după care aducem conţinutul fişierului
temporar cu File>Import Contents...

(4) Definim cadrele importând fragmentele BeginFrame şi EndFrame.
(5) Vizualizăm rezultatul cu Typeset>Preview PDF...
(6) Repoziţionăm (cu copy/paste) BeginFrame şi EndFrame pentru ca-

drele ı̂n care textul excede fereastra.
(7) Există şi posibilitatea ca ı̂mpărţirea pe cadre să fie făcută auto-

mat. Pentru aceasta, cu meniul contextual al lui [BeginFrame] ,

ı̂nlocuim \begin{frame} cu \begin{frame}[allowframebreaks]. În
felul acesta, pentru tot conţinutul până la următorul EndFrame care
nu ı̂ncape ı̂ntr-un singur cadru, vor fi generate cadre suplimentare (cu
riscul ca ı̂mpărţirea să nu fie tocmai logică); la titlul noilor cadre va fi
adăugat automat un număr de ordine: I, II, III, etc.

Notă. Clasa beamer oferă şi alte posibilităţi, inclusiv includerea unor ele-
mente multimedia, descrise ı̂n documentaţia SWP.

6. RECOMANDĂRI PRIVIND PUNCTUAŢIA

• Cratima (e.g.
”
propriu-zis”) se introduce cu tasta minus. Semnul

minus este mai lung şi apare doar ı̂n mod matematic (e.g. a−1). Linia
de pauză, folosită pentru a marca intervale şi uneori ı̂n enumerări (e.g.

”
ı̂n perioada 1–10 iunie”), se introduce tastând de două ori minus.
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Ocazional, ı̂n special ı̂n tipografia engleză, este utilizată o linie mai
lungă numită m-dash, obţinută tastând de trei ori minus.
• Punctul de sfârşit de propoziţie/frază este lipit de cuvântul precedent

şi este urmat obligatoriu de un spaţiu. La fel pentru virgulă, punct-
virgulă, semnul exclamării, semnul ı̂ntrebării sau puncte de suspensie

(obţinute cu CTRL+ ldots ). Utilizarea a trei puncte succesive nu este
recomandată, punctele fiind prea apropiate (potrivit normelor tipogra-
fice). Varianta. . . (corectă) şi... (incorectă).

• În mod text, parantezele sunt lipite de textul pe care ı̂l ı̂ncadrează şi
sunt precedate de spaţiu (ca aici).
•

”
Ghilimelele” ı̂n limba română au aspectul

”99
. . .99” şi sunt lipite de

text; uneori apar şi sub forma
”99

. . .66“ dar Academia Română reco-
mandă prima variantă. Se preiau din ultima pictogramă a barei de
simboluri.

În limba engleză se utilizează ‘quotes’, “double quotes” (obţinute la
stânga cu accent grav, la dreapta cu apostrof).

“I write a little. I erase a lot.” — Chopin

”
Scriu puţin. Şterg mult.” — Chopin3

• Ocazional, despărţirea automată ı̂n silabe a unui cuvânt românesc
poate fi incorectă. Dacă observăm o asemenea situaţie, putem intro-
duce manual regula de despărţire, poziţionând cursorul după fiecare
silabă şi tastând CTRL+ – – . O altă soluţie (globală) este plasarea
ı̂n preambul a unei linii de tipul
\hyphenation{ac-tu-al re-co-man-da-re prin-ci-pii}

7. PROBLEMA DIACRITICELOR ROMÂNEŞTI

Faptul că SWP nu utilizează caractere UNICODE face să nu poată fi intro-
duse de la tastatură diacriticele româneşti

”
ş”,

”
ţ” ı̂n fereastra SWP. Acest

fapt neplăcut se ı̂ntâmplă pentru sistemele de operare Windows ı̂ncepând cu
Vista, când, diacriticele româneşti

”
s,”,

”
t,” au fost schimbate la varianta (co-

rectă din punctul de vedere al limbii române) cu virgulă ı̂n loc de sedilă.
SWP nu este singurul program afectat, ci (aproape) toate programele non-
UNICODE.

Soluţia este dată de driverul de tastatură al lui Cristian Secară
(http://www.secarica.ro) care face revenirea la ş, ţ cu sedilă (incorecte
dar deocamdată utile). Până la o versiune UNICODE a lui SWP este singura
soluţie comodă. Pentru programele UNICODE ar trebui selectat driverul de

3Cu privire probabil la faptul (adevărat?) că un compozitor (sau matematician!) are
nevoie ı̂n procesul de creaţie de hârtie+creion+radieră, spre deosebire de un filozof, care se
poate dispensa de ultima ustensilă.
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tastatură corect, altfel existând riscul de haos căci la modificarea unui docu-
ment Word (de exemplu), pot să apară ambele tipuri de caractere (cu coduri
diferite)4.

Pentru Windows Vista şi Windows 7, driverul lui C. Secară descărcat de la
http://www.secarica.ro/

kbdro 2.3 prg cedilla 32bit 64bit xp vista 7 ro.zip

va trebui instalat pentru fiecare cont (din Control Panel).

O soluţie alternativă mai puţin comodă ar fi definirea unor fragmente pentru
diacriticele incriminate. De exemplu pentru litera ş definim (salvăm) fragmen-
tul zs.frg care să conţină litera ı̂n cauză (preluată din bara

”
Latin Extended-

A”). Litera ş se va putea acum obţine tastând CTRL+ zs . Similar pentru Ş,
ţ, Ţ.

Din păcate va mai dura până când problema cu diacriticele corecte ı̂n
limba română va fi complet rezolvată. De exemplu, deocamdată, despărţirea
automată ı̂n silabe, corectorul gramatical şi căutarea cuvintelor cu diacritice
româneşti ı̂n fişierele pdf (̂ın special ş, ţ) sunt problematice.

Notă. Pentru a genera cu SWP fişiere pdf cu diacritice româneşti ş, ţ
corecte (cu virgulă ı̂n loc de sedilă) se poate aplica următoarea metodă arti-
zanală:

(1) Se adaugă pachetele (cu meniul Typeset>Options and Packages...)
inputenc (cu opţiunea latin10) şi ifthen

(2) Se adaugă ı̂n preambul liniile
\let\oldc\c
\renewcommand{\c}[1]{\ifthenelse%
{\equal{#1}{s}\or\equal{#1}{S}\or%
\equal{#1}{t}\or\equal{#1}{T}}%
{\textcommabelow{#1}}{\oldc{#1}}}

8. CÂTEVA INFORMAŢII DE ORDIN MAI TEHNIC

• În urma compilării se poate ı̂ntâmpla ca umplerea optimă a pagini-
lor să nu reuşească. Acest fapt este transmis utilizatorului ı̂n fe-
reastra cu mesaje ale compilatorului (care este salvată şi ı̂ntr-un
fişier .log ı̂n directorul unde se află documentul). Apar aici linii
care ı̂ncep cu Overfull \hbox, Overfull \vbox, Underfull \hbox
şi Underfull \vbox, şi conţin numărul liniei incriminate din fişierul
tex şi o parte a conţinutului ei. (Primul tip de mesaj se referă la su-
prâıncărcare pe orizontală iar ultimul la sub̂ıncărcare pe verticală.)
Câteva soluţii posibile (urmate de recompilare):

4Acest haos lingvistic există oricum deoarece multe documente conţin ambele tipuri de
caractere. Totul se datorează autorităţilor autohtone care au ignorat gravitatea fenomenului,
fiind absorbite de normări precum ı̂→â sau

”
nici o”→

”
nicio”.
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– Examinând fişierul pdf, rezultatul este acceptabil (nu apar
depăşiri prea mari ı̂n marginea din dreapta şi nici cuvinte sau
rânduri prea rare).

– Pentru a cobor̂ı standardele LATEX-ului, se include ı̂n preambul
linia
\sloppy

– Se reformulează liniile ı̂n cauză, se definesc eventual regulile de
despărţire ı̂n silabe (v. secţiunea 6).

– Utilizând meniul Insert> Spacing> Break se forţează un sfârşit
de pagină cu Newpage (exact ı̂n locul indicat) sau cu Page-
break (după linia curentă).
SWP nu oferă prin meniu posibilitatea ca ı̂ntr-un anume loc să
fie interzis un sfârşit de pagină, dar se poate ı̂n acest scop fo-
losi Insert >Typeset Object>TeX Field... şi se tastează
\nopagebreak.

– Utilizând meniul Insert> Spacing> Vertical Spaces se intro-
duce spaţiu pe verticală: Big Skip, Medium Skip, Small Skip
sau de lungime precizată (care poate fi şi negativă).

• În SWP pot fi deschise fişiere .tex provenite din alte surse, cu condiţia
să nu conţină construcţii LATEX prea complicate. Dacă deschiderea
fişierului eşuează se poate ı̂ncerca deschiderea sa prin meniul File>
Import Non SW/SWP LaTeX... Este posibil să fie nevoie totuşi de
modificarea fişierului ı̂n cauză, aceasta presupunând evident cunoştinţe
de LATEX.
• Pentru ca un fişier .tex generat de SWP să poată fi utilizat ı̂ntr-un

alt sistem LATEX se recomandă salvarea sa (cu Save as...) ı̂n varianta
portable.
• Fişierele .cst conţin informaţii privind aspectul documentului ı̂n fe-

reastra SWP; nu influenţează aspectul tipăririi. Modificarea acestora
se realizează cu meniul Tag>Appearance...
• Fişierele .shl conţin fişiere .tex valide (numite shell) cu care este

ı̂ncărcat SWP la comanda File>New... Ele conţin şi numele .cst-
ului folosit. De fapt, orice fişier .tex generat de SWP conţine linii de
tipul

%TCIDATA{CSTFile=LaTeX article (bright).cst}
Aceste linii vor fi interpretate de SWP dar ignorate (fiind comenta-

rii) de alte distribuţii LATEX. Există o linie similară conţinând numele
fişierului de shell ı̂ncărcat, aceasta fiind ı̂nsă doar informativă.

Orice document poate fi declarat ca shell prin meniul File>Export
Document...
• Pentru a publica ı̂ntr-o revistă care pretinde un stil propriu:

– plasaţi fişierele .cls, .clo, .sty ı̂ntr-un director nou creat ı̂n
TCITeX\TeX
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– unele fişiere furnizate de editor ar putea să aibă nevoie de instalare
ı̂n sistemul LATEX al SWP; ı̂n acest caz fişierul trebuie ı̂ncărcat
ı̂n TrueTeX Formatter. Trebuie evident citită documentaţia!

• SWP nu acceptă direct suprapuneri de tag-uri pentru ı̂ntreaga ex-

presie. Pentru a scrie cuvântul bolditalic cu tag-urile bold+italic se
aplică tag-ul Italics cuvântului extins cu 2 caractere e.g. !bolditalic!,
după care se aplică tag-ul Bold dar fără a include ı̂n selecţie acele ca-
ractere: !bolditalic!. În final caracterele suplimentare vor fi şterse,

rezultând bolditalic .
• Dacă se doreşte ca numerotarea teoremelor să fie plasată la ı̂nceputul

rândului (de forma 2.3 Theorem. Enunţ. . . ), procedăm astfel:

(1) Încărcăm pachetul amsthm.
(2) Scriem ı̂n preambul comanda \swapnumbers ı̂nainte de prima

linie \newtheorem.
(3) Tot ı̂n preambul inserăm comanda \iffalse la ı̂nceputul liniei
\newenvironment{proof}... şi \fi la sfârşitul acestei linii.

• În Beamer, fiecare titlu de la bibliografie este precedat de o pictogramă

”
pagină de articol” ; aceasta se poate schimba (pentru următorii

itemi) ı̂n pictograma
”
carte” folosind meniul Insert >Typeset

Object>TeX Field... ı̂n care se completează
\setbeamertemplate{bibliography item}[book]
(̂ın afară de book, mai există: online, article, triangle, text5).
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5Cu text, pictogramele sunt ı̂nlocuite cu numere de ordine uzuale şi pot fi făcute citări
ca ı̂n 4.5


